Stephen's Thoughts, and Other Nonsense...

<?php echo $cleverComments[array_rand($cleverComments)]; ?>

ThinkPad L520 + Ubuntu

I'm a big Thinkpad fan. My first was a Thinkpad R40, which still hasn't died, I then moved to an T61 when the R40 was getting too slow. The T61 was a fantastic machine, but it suddenly died one day without warning. So I upgraded to an L520, and it's been an interesting journey.

All of my previous Thinkpads before the L520 worked flawlessly with Ubuntu, but the L520 has some issues. This page is my attempt at providing a list of issues I've encountered and solutions I've discovered or been told about, when using Ubuntu on a Thinkpad L520.

My Thinkpad L520 Specifications

  • Lenovo ThinkPad L520 (7859CTO)
  • BIOS: 8GET46WW (1.23) 09/16/2013
  • Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
  • 6 GB DDR3 SDRAM
  • 15.6″ HD+ (1600×900)
  • Intel HD Graphics 3000 processor graphics
  • 500GB Hard Disk Drive, 7200rpm

Important - BIOS Update Information

All of the issues reported below have been resolved either with newer versions of Ubuntu, or with the BIOS update for the L520 to version 1.23 that Lenovo provided in October 2013.

The most notible issue that it resolves is the need to set the noapic boot flag in GRUB to get Ubuntu to actually boot successfully. After applying this update, the boot flag is no longer needed,

The update is available in their device drivers download system, and comes as an ISO so you don’t need Windows to install it.

Blank Screen on Installation

Affects: BIOS < v1.23 only - I've tested v1.23 Ubuntu 13.10 and it works without the boot flag..

Problem: The screen goes blank (often with a cursor in the top corner) when trying to run the installer.

Solution: We need to enable the noapic option, which from my tests appears to have the best results.

  1. Use either the Alternate Installer, or press a key when the purple screen comes up with the little white keyboard logo.
  2. Press F6 and select noapic from the options.
  3. Press Esc and then Enter to Install Ubuntu.
  4. Ubuntu should now install correctly.

Blank Screen on Boot

Affects: BIOS < v1.23 only - I've tested v1.23 Ubuntu 13.10 and it works without the boot flag..

Problem: This follows the previous issue, after Ubuntu is installed, it still throws to a blank screen when it boots.

Solution: We need to enable the noapic option, first in GRUB manually to get into Ubuntu, and then into the GRUB config so it remembers it each time.

  1. Hold down Shift when the BIOS screen is up, and keep it down until the GRUB menu appears.
  2. Press E to bring up the edit box.
  3. Locate the line containing the words: quiet splash.
  4. Add noapic to the line after splash.
  5. Press Ctrl+X to boot into Ubuntu with the new option.
  6. Once logged into Ubuntu, edit the GRUB config file: /etc/default/grub.
  7. Locate the GRUB_CMDLINE_LINUX_DEFAULT option and add noapic to it.
  8. Save the GRUB config file and update GRUB: sudo update-grub.
  9. Ubuntu should now boot successfully.

Weird colours and lines across the screen on Boot.

Affects: Ubuntu 11.04.

Problem: Sometimes when I boot into Ubuntu, I end up with a screen full of weird coloured lines and patterns, making it totally unusable.

Solution: I found this solution on the Lenovo Forums:

  1. Press Fn+F4 to put the computer to sleep.
  2. Once the computer is asleep, press the power button to wake it up and the display should be back to normal.

Screen freezes instead of showing screensaver.

Affects: Ubuntu 11.04.

Problem: I left my laptop copying files from my media box into it for a number of hours. When I got back to it the screen was frozen on the copy window. Although the mouse moves around on the screen, it cannot interact with anything.

Solution: I found restarting GDM does the trick.

  1. Press Ctrl+Alt+1.
  2. Login at the prompt.
  3. Run: sudo /etc/init.d/gdm restart.
  4. You should get a login window, and be back into Ubuntu in a few moments :)

Unity UI freezes/stutters every couple of seconds

Affects: Ubuntu 11.04.

Problem: Unity freezes every couple of seconds for a second or two, and playing games results in freezing video (particularly OpenGL games).

Solution: I found this solution on AskUbuntu, which solves the issues in Games but not in normal usage:

  1. Edit your GRUB config (sudo vim /etc/default/grub).
  2. Locate the GRUB_CMDLINE_LINUX_DEFAULT option and add i915.semaphores=1 to it.
  3. Save the GRUB config file and update GRUB: sudo update-grub.
  4. Restart, and that should solve the problem.

For those who are interested, that line in my GRUB file looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic i915.semaphores=1"

If you have any other issues, or know of any other solutions, let me know.

;